2010年01月一覧

Vista SP2でHyperV管理ツールを(続2)

仮想ネットワークを設定なし(作らない)でHyper-Vを再構築してみたら、
昨日の手順でつながった!

どうやら問題はネットワークアダプタの問題まで絞り込めた。

幸い実験PCにはもう1つネットワークカードを刺していたので、
そちらのほうで同じ症状が起こるかテストしてみた。

試してみたカードは、
Intel Pro/1000GT Desktop Adapter


結果は、正常に動いてる。
このカード上にHyper-Vの仮想ネットワークアダプタを設定し、
さらにこちらのボードを使って通常のLANに接続するようにしてみても問題なし。

おまけに、あれだけ苦戦していたリモートによるHyper-V管理も問題なさげで。

通常使用の Marvell Yukon 88E8056 では使用に耐えないという結論で終了のようだ。
このあたりはさすがIntel NICといったところかな。


Vista SP2でHyperV管理ツールを(続)

Windows Vista for x64-based Systems 用の更新プログラム (KB952627)
をインストール。昨日のはx86版だったようで。

ダウンロード: KB952627 x64版

続いて KB970203をインストールしてみる。

ダウンロード: KB970203 x64版

昨日はこれら適用の段階でも、
”適用する必要はありません”だったのに、今回は正常にインストールされた。



しかし、症状はそのままあいかわらずで、結局うまく操作できません。
リモートデスクトップを使えるように設定して、この場をしのいでみようかと思います。


Vista SP2でHyperV管理ツールを

基本的に参考にしたのは http://www.atmarkit.co.jp/fwin2k/win2ktips/1106hvremote/hvremote.html のページです。
しかし、VistaSP2ではこのままではいくつかうまくいかなかったので、多少試行錯誤しています。

VistaSP2(x64)にHyper-V管理ツールを入れる

KB952627を下記の英語のフォーラムのなかにあったURLからインストール。
日本語のKBではだめでした。古いのかもしれない。

http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/8a0131f0-3663-423f-9afb-66d458274e7e

HVRemoteスクリプトを取得

今回Hyper-Vを動かすサーバーはドメイン不参加マシンのため、ワークグループで作業することに。
そのためには色々と準備が必要です。

まず、次の場所から設定スクリプトをダウンロードしておきます。
http://code.msdn.microsoft.com/HVRemote

サーバーとクライアント両方に必要です。
ダウンロードした後は、C:Windowsなどにコピーして使います。
また、管理者としてのコマンドプロンプトで下記のコマンドを実行しておきます。

cscript //h:cscript

サーバーで作業

コマンドプロンプトで実行します。

HVRemote /add:server01hvmanagement

server01がマシン名、hvmanagementが管理権限を持つユーザー名とします。

クライアントで作業

HVRemote /mmc:enable
HVRemote /AnonDCOM:grant

もし、クライアント側で使っているユーザーと、サーバーでの管理ユーザーが別物で、
普段クライアント側で使っているユーザーで管理作業したい場合には、
“別のユーザー資格情報でログインする”を利用しておくとよいらしい。

cmdkey /add:server01 /user:hvmanagement /pass

ここでパスワードも入力して、クライアント側でデータを保持しておく。

ここまで実行できたら、Vista(SP2)上に追加されたHyper-Vマネージャを起動して
接続できることを確認してみる。

ファイアウォールの再設定

・・・接続できない。
結果としてはファイアウォールで阻まれているところまで突き止めたもののどれが原因なのか不明。
全ファイアウォールをOFFにすれば動くものの、いくら内部ネットワークとはいえやりたくはない。

とりあえずWindowsファイル共有のポートを許可するようにしたところ、やっと動き出した。
あまりこれもあけたくはなかったが仕方ないのかも。。。

  • ファイルとプリンターの共有=>プライベートネットワークにのみチェックを入れる

[追記]
それでもマシンを構成直後でやはりエラー。うーん、なかなかうまくいかない。


VMwareの仮装マシンでMACアドレスを指定する

ゲストOSの構成ファイルを開き、以下の行を削除します。
ethernet[n].generatedAddress
ethernet[n].addressType
ethernet[n].generatedAddressOffset

そして、設定したいアドレスを次のように書く。

ethernet[n].addressType=”static”
ethernet[n].address=”xx:xx:xx:xx:xx:xx”

ずっと、generateAddressの中身を書き換えて、うまくいかないなーと思っていたら、
3行全部削除必要だったというわけです。
1つでも残ると毎回生成されてしまって、何度もやりなおしました。

あとは、addressType=”static”これも必要でした。


あけおめことよろ

2010年 あけましておめでとうございます。

2009年は環境が色々と変わったし、仕事もプライベートもホントに忙しい年でした。
今年はすこしゆっくりした1年になったらなーと思います。

そんな中初詣は明治神宮にチャレンジしてくる予定です。

やりたいことリスト

  • Windows7入れる
  • GeForce9800か9600かかいたい・・・。

紅白見てたけど、水樹奈々の出番がホント少なくて残念。
深愛もっと長くやってほしかったな。